Level Get |
Returns id of the Level which is closest to the specified elevation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElementId GetNearestLevelId(
Document document,
double elevation,
out double offset
)
Parameters
- document Document
- The document.
- elevation Double
- Target Elevation.
- offset Double
- Vertical offset from the level to the target elevation.
Return Value
ElementId
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.