SuppressSpaces Property


Format Options Suppress Spaces Property

Indicates if spaces around the dash should be suppressed in feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool SuppressSpaces { get; set; }

Property Value

Boolean
True if spaces should be suppressed, false otherwise. The default is false.
Exceptions
Exception Condition
InvalidOperationException UseDefault is true in this FormatOptions. -or- When setting this property: SuppressSpaces was set to true but spaces cannot be suppressed for the display unit in this FormatOptions.
Remarks

This property is applicable to display units related to feet and fractional inches:

  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressLeadingZeros is true, spaces will not be inserted before and after the dash separating feet from inches. For example, 1' - 2 3/4" will be displayed as 1'-2 3/4".

See Also