GetPartCustomDataText Method


Fabrication Part Get Part Custom Data Text Method

Get custom data text for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetPartCustomDataText(
	int customId
)

Parameters

customId Int32
The identifier of the custom data field to get.

Return Value

String
Returns the text of the custom data. If the data is a number it will be formatted according to the fabrication configuration's rules.
Exceptions
Exception Condition
ArgumentException The custom data does not exist on the part.
See Also