WireSizeSet Class


Wire Size Set Class

A set that contains wire sizes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical WireSizeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireSizeSet : APIObject, 
	IEnumerable

The WireSizeSet type exposes the following members.

Constructors
Name Description
Public method WireSizeSet Initializes a new instance of the WireSizeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of wire sizes that are in the set.
Top
Methods
Name Description
Public method Clear Removes every wire size from the set, rendering it empty.
Public method Contains Tests for the existence of a wire size within the set.
Public method Erase Removes a specified wire size from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified wire size into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also