Application Open |
Opens a document from disk or cloud.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- modelPath ModelPath
- The file to be opened.
- openOptions OpenOptions
- Options for opening the file.
Return Value
DocumentThe opened document.

Exception | Condition |
---|---|
ArgumentException | The modelPath to be opened is empty. |
ArgumentNullException | A non-optional argument was null |
CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session. |
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance. |
CentralModelContentionException | The model on the RevitServer is being accessed by other users. -or- The central model is locked by another client. |
CentralModelException | Revit encountered serious errors while trying to open the central model. -or- An internal error happened on the central model, please contact the server administrator. |
CorruptModelException | There are too many corrupt elements to open this model. |
FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again. -or- File was saved by an application that was not developed or licensed by Autodesk. |
FileNotFoundException | The modelPath to be opened doesn't exist. -or- File Not Found |
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model. |
InvalidOperationException | Open is temporarily disabled. -or- The cloud model is not saved in current release of Revit. -or- The model is not allowed to access. -or- The document can not be opened. -or- Revit cannot save the transmitted model as a new central because it is already opened. |
OperationCanceledException | Opening was canceled by the user or by an API event callback. |
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |
RevitServerInternalException | An internal error happened on the server, please contact the server administrator. |
RevitServerUnauthorizedException | User is not authorized to access the cloud model. |
ServerModelCorruptedException | The central model is corrupted. This exception is treated starting from Revit 2025.2. |
WrongUserException | The local file is not owned by the current user, who therefore is not allowed to modify it. |

This method opens the document into memory but does not make it visible to the user in any way. If the user currently has ownership of elements in this model and there is no local model on this machine, Revit will post a warning.