SetAllowed Method


Rebar Shape Set Allowed Method

Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAllowed(
	RebarBarType barType,
	bool allowed
)

Parameters

barType RebarBarType
A bar type in the same document as this shape.
allowed Boolean
Whether this shape may be combined with barType.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also