GetClosedShell Method


Energy Analysis Space Get Closed Shell Method

Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces, if in rooms and spaces mode. In other modes, returns no polyloops.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<Polyloop> GetClosedShell()

Return Value

IList Polyloop
the collection of polygons that form a closed shell.
See Also