Temporary |
Tests whether the given state is valid for the associated view and the context the view is currently in.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- state PreviewFamilyVisibilityMode
- A state of the PreviewFamilyVisibilityMode
Return Value
BooleanReturns True if the state is applicable for the view; False otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

As long as the PreviewFamilyVisibility mode is available and enabled in the associated view, the Off and On states are always valid. However, the Uncut state is only valid in plan views and reflected ceilings.