Transform Class |
A transformation of the affine 3-space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Transform type exposes the following members.


Name | Description | |
---|---|---|
![]() | Basis | Defines the basis of the old coordinate system in the new coordinate system. |
![]() | BasisX | The basis of the X axis of this transformation. |
![]() | BasisY | The basis of the Y axis of this transformation. |
![]() | BasisZ | The basis of the Z axis of this transformation. |
![]() | Determinant | The determinant of this transformation. |
![]() | HasReflection | The boolean value that indicates whether this transformation produces reflection. |
![]() ![]() | Identity | The identity transformation. |
![]() | Inverse | The inverse transformation of this transformation. |
![]() | IsConformal | The boolean value that indicates whether this transformation is conformal. |
![]() | IsIdentity | The boolean value that indicates whether this transformation is an identity. |
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | IsTranslation | The boolean value that indicates whether this transformation is a translation. |
![]() | Origin | Defines the origin of the old coordinate system in the new coordinate system. |
![]() | Scale | The real number that represents the scale of the transformation. |

Name | Description | |
---|---|---|
![]() | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09). |
![]() ![]() | CreateReflection | Creates a transform that represents a reflection across the given plane. |
![]() ![]() | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0). |
![]() ![]() | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point. |
![]() ![]() | CreateTranslation | Creates a transform that represents a translation via the specified vector. |
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Multiply | Multiplies this transformation by the specified transformation and returns the result. |
![]() | OfPoint | Applies the transformation to the point and returns the result. |
![]() | OfVector | Applies the transform to the vector |
![]() | ScaleBasis | Scales the basis vectors of this transformation and returns the result. |
![]() | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Name | Description | |
---|---|---|
![]() ![]() | Multiply(Transform, Transform) | Multiplies the two specified transforms. |