Structural |
Obtains the StructuralConnectionSettings object for the specified project document.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static StructuralConnectionSettings GetStructuralConnectionSettings(
Document document
)
Parameters
- document Document
- A project document.
Return Value
StructuralConnectionSettingsThe StructuralConnectionSettings object.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. |
ArgumentNullException | A non-optional argument was null |