ForegroundPatternId Property


Filled Region Type Foreground Pattern Id Property

The foreground fill pattern Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId ForegroundPatternId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The patternId must either be InvalidElementId or represent a valid FillPatternElement. -or- When setting this property: In a family the patternId must be a 'Drafting' pattern. -or- When setting this property: In a family the patternId can not be a solid fill pattern if the 'IsMasking' property is false.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
When the FilledRegionAttributes element is in a family then the FillPattern used for a foreground pattern must have a 'Drafting' target. In addition, when the FilledRegionAttributes element is in a family, the pattern cannot be the solid fill pattern unless the 'IsMasking' property is set to true. InvalidElementId is used when there is no foreground pattern
See Also