IsValidShortName Method


External Resource Server Utils Is Valid Short Name Method

Checks whether the name is a valid short name for the external resource server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidShortName(
	Guid serverId,
	string serverName
)

Parameters

serverId Guid
The id of the external resource server.
serverName String
The short name of the external resource server.

Return Value

Boolean
True if the name is a valid short name, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
A valid short name should match the restrictions documented in GetShortName .
See Also