Schema |
Creates a field containing a single value in the Schema, with given name and type.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
FieldBuilderThe FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.

Exception | Condition |
---|---|
ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The SchemaBuilder has already finished building the Schema. |

The supported types are Boolean, Byte, Int16, Int32, Int64, Float, Double, ElementId, GUID, String, XYZ, UV and Entity.
Note that data of type ElementId is not copied to new elements that are created via copy/paste or a linear or radial array.
Note that a schema may contain a maximum of 256 fields.