ValueParsingOptions Class


Value Parsing Options Class

Options for parsing strings into numbers with units.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ValueParsingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ValueParsingOptions : IDisposable

The ValueParsingOptions type exposes the following members.

Constructors
Name Description
Public method ValueParsingOptions Creates a new ValueParsingOptions object with default settings.
Top
Properties
Name Description
Public property AllowedValues The allowable range of values to be parsed.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ValueParsingOptions
Public method GetFormatOptions Gets the FormatOptions to optionally override the default settings in the Units class.
Public method SetFormatOptions Sets the FormatOptions to optionally override the default settings in the Units class.
Top
See Also