ConduitSizes Class


Conduit Sizes Class

Class ConduitSizeSet being used to store the conduit sizes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ConduitSizes

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConduitSizes : IEnumerable<ConduitSize>, 
	IDisposable

The ConduitSizes type exposes the following members.

Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Contains Checks whether a conduit size with the nominal diameter exists.
Public method Dispose Releases all resources used by the ConduitSizes
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetConduitSizesIterator Returns a ConduitSizeIterator to the conduit sizes.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Top
See Also