Label
|
Gets the user-visible name for a spec.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- specTypeId ForgeTypeId
- Identifier of the spec to get the user-visible name.
Return Value
StringReturns the user-visible name for a spec.

Exception | Condition |
---|---|
ArgumentException | The given identifier is neither a spec nor a category. |
ArgumentNullException | A non-optional argument was null |

The name is obtained in the current Revit language.
If the given identifier is a category, this method returns the name
of the Family Type spec with that category, e.g. "Family Type: Walls".