NosingProfile Property


Stairs Run Type Nosing Profile Property

The id of the nosing profile of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId NosingProfile { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The profile is neither a valid element id nor invalidElementId. -or- When setting this property: The profile is not a valid nosing profile symbol.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The run type has no tread so the data being set is not applicable.
See Also