GetLayerAssociatedToRegion Method


Compound Structure Get Layer Associated To Region Method

Gets the layer associated to a particular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetLayerAssociatedToRegion(
	int regionId
)

Parameters

regionId Int32
The id of a region.

Return Value

Int32
The index of a layer in this CompoundStructure.
Exceptions
Exception Condition
ArgumentsInconsistentException For a non-vertically compound structure, implicitly each layer is associated to its corresponding simple region.
See Also