ArgumentOutOfRangeException Class


Argument Out Of Range Exception Class

The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class ArgumentOutOfRangeException : ArgumentException

The ArgumentOutOfRangeException type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetObjectData Retrieves data needed to serialize the target object.
(Overrides ArgumentException GetObjectData(SerializationInfo, StreamingContext) )
Top
See Also