Panel |
Checks if given type is valid for this panel schedule template element.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- panelScheduleType PanelScheduleType
- The given type to check.
Return Value
BooleanTrue if panel schedule template can have a type assigned and this type is valid for this element, false otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

A type is valid for a panel schedule template element if it is defined by the PanelScheduleType class. Note: PanelScheduleType::Enum::Unknown is not a valid type, it is used for initializing the variable of the PanelScheduleType::Enum.