RoutingCriterionBase Class


Routing Criterion Base Class

RoutingCriteriaBase is the base class for all routing criteria.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RoutingCriterionBase
Autodesk.Revit.DB PrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoutingCriterionBase : IDisposable

The RoutingCriterionBase type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RoutingCriterionBase
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEqual Verify if two criteria are the same.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also