Stairs |
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public static StairsRun CreateSketchedRunWithSlopeData(
Document document,
ElementId stairsId,
double baseElevation,
IList<SketchedStairsCurveData> boundaryCurves,
IList<Curve> riserCurves,
IList<Curve> stairsPath
)
Parameters
- document Document
- stairsId ElementId
- baseElevation Double
- boundaryCurves IList SketchedStairsCurveData
- riserCurves IList Curve
- stairsPath IList Curve
Return Value
StairsRun