Normalize Method


XYZ Normalize Method

Returns a new XYZ whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ Normalize()

Return Value

XYZ
The normalized XYZ or zero if the vector is almost Zero.
Remarks
Normalized indicates that the length of this vector equals one (a unit vector).
See Also