ConduitSizeSettingIterator Class


Conduit Size Setting Iterator Class

An iterator to a set of items from ConduitSizeSettings. Each item is a KeyValuePair(System::String^, ConduitSizes). ElementId is the id of the conduit standard type.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ConduitSizeSettingIterator

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConduitSizeSettingIterator : IEnumerator<KeyValuePair<string, ConduitSizes>>

The ConduitSizeSettingIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ConduitSizeSettingIterator
Public method HasCurrent Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the enumerator to the next item.
Public method Reset Resets the iterator to the initial state.
Top
See Also