ChangePointElevation Method


Topography Surface Change Point Elevation Method

Note: This API is now obsolete.

Changes the elevation value for a point.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements.  It is recommended that TopographySurface elements should be converted to Toposolid elements to enable better editing options.")]
public void ChangePointElevation(
	XYZ point,
	double elevationValue
)

Parameters

point XYZ
The point to be modified.
elevationValue Double
The new elevation value.
Exceptions
Exception Condition
ArgumentException The input point does not exist in the current topography surface.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for elevationValue must be no more than 30000 feet in absolute value.
InvalidOperationException This element is not a TopographySurface. -or- The points of this topography surface are not editable. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface.
ModificationForbiddenException The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document containing this TopographySurface has no open transaction.
Remarks
If the point doesn't exist in the current TopographySurface, an exception will be thrown. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which should be in an active TopographyEditScope.
See Also