SetTagRelativeRotation Method


Rebar Bending Detail Set Tag Relative Rotation Method

Sets the embedded tag rotation angle w.r.t. the realistic bending detail element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetTagRelativeRotation(
	Element bendingDetail,
	double rotation
)

Parameters

bendingDetail Element
The bending detail element.
rotation Double
The new rotation angle of the embedded tag w.r.t. the bending detail element.
Exceptions
Exception Condition
ArgumentException This option is only available for realistic bending detail elements. -or- The given value for rotation is not a number -or- The given value for rotation is not finite
ArgumentNullException A non-optional argument was null
Remarks
This function is exclusive to realistic bending detail mode.
See Also