IsInside Method (Double, Int32)


Curve Is Inside(Double, Int 32 ) Method

Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsInside(
	double parameter,
	out int end
)

Parameters

parameter Double
The raw curve parameter to be evaluated.
end Int32
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

Boolean
True if the parameter is within the curve's bounds, otherwise false.
Remarks
Always returns true if this curve is unbound.
See Also