Create Method


Curve UV Create Method

Create a CurveUV from a bounded 3D Curve lying in the XY plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveUV Create(
	Curve curve3D
)

Parameters

curve3D Curve
The input bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).

Return Value

CurveUV
The newly created CurveUV.
Exceptions
Exception Condition
ArgumentException The input Curve is not a bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).
ArgumentNullException A non-optional argument was null
Remarks
The XY plane is identified with the uv parameter space of the surface to which this SurfParamSpaceCurve refers.
See Also