TransformAndScaleVector Method


Exporter IFCUtils Transform And Scale Vector Method

Converts a vector from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static XYZ TransformAndScaleVector(
	ExporterIFC exporterIFC,
	XYZ origVector
)

Parameters

exporterIFC ExporterIFC
The exporter.
origVector XYZ
The original vector.

Return Value

XYZ
The transformed and scaled point.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also