PlaceOnHost Method


Fabrication Hosted Info Place On Host(Element Id, Connector, Double) Method

Places the part on the specified host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PlaceOnHost(
	ElementId hostId,
	Connector hostConnector,
	double distance
)

Parameters

hostId ElementId
Identifier of the host fabrication part.
hostConnector Connector
The connector of the host.
distance Double
The distance from the connector to place the hosted part. Units are in feet (ft).
Exceptions
Exception Condition
ArgumentException Invalid fabrication part host. The host should be a straight fabrication part. -or- Invalid connector of fabrication part host. -or- The distance is out of range.
ArgumentNullException A non-optional argument was null
Remarks
The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also