Categories Class


Categories Class

The Categories object is a map that contains all the top-level Category objects within the Document.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Categories : CategoryNameMap

The Categories type exposes the following members.

Properties
Name Description
Public property IsEmpty Whether or not the list of top-level categories is empty.
(Overrides CategoryNameMap IsEmpty )
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Item BuiltInCategory Retrieves a category object corresponding to a BuiltInCategory id.
Public property Item String Gets a category which has the specified name from this list of top-level categories.
(Overrides CategoryNameMap Item String )
Public property Size The total number of top-level categories in the document.
(Overrides CategoryNameMap Size )
Top
Methods
Name Description
Public method Clear Removes every category from the map, rendering it empty.
(Inherited from CategoryNameMap )
Public method Contains Identifies if a category which has the specified name is in the list of top-level categories.
(Overrides CategoryNameMap Contains(String) )
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Erase Removes a category with the specified name from the map.
(Inherited from CategoryNameMap )
Public method ForwardIterator Retrieves a forward moving iterator to the map.
(Overrides CategoryNameMap ForwardIterator )
Public method GetEnumerator Retrieves a forward moving iterator to the map.
(Overrides CategoryNameMap GetEnumerator )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert Inserts the specified category with the specified name into the map.
(Overrides CategoryNameMap Insert(String, Category) )
Public method NewSubcategory Add a new subcategory into the Autodesk Revit document.
Public method ReverseIterator Retrieves a backward moving iterator to the map.
(Overrides CategoryNameMap ReverseIterator )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Use this object to retrieve categories by name or by BuiltInCategory id.
See Also