LoadFamily Method (String, Family)


Document Load Family(String, Family ) Method

Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool LoadFamily(
	string filename,
	out Family family
)

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
family Family
A reference to the family that was loaded if successful, otherwise .

Return Value

Boolean
True if the entire family was loaded successfully into the project, otherwise False.
Exceptions
Exception Condition
ArgumentException Thrown when filename is or empty.
Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

See Also