SetMajorLayoutAsFixedNumber Method


Fabric Sheet Type Set Major Layout As Fixed Number Method

Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMajorLayoutAsFixedNumber(
	double overallWidth,
	double minorStartOverhang,
	double minorEndOverhang,
	int numberOfWires
)

Parameters

overallWidth Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang Double
The distance from the edge of the sheet to the first wire in the minor direction.
minorEndOverhang Double
The distance from the last wire to the edge of the sheet in the minor direction.
numberOfWires Int32
The number of the wires to set in the major direction.
Exceptions
Exception Condition
ArgumentException The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for minorEndOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The arguments are not consistent, please specify proper input values.
ArgumentOutOfRangeException The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for minorEndOverhang must be between 0 and 30000 feet.
See Also