ComboBoxCurrentChangedEventArgs Class


Combo Box Current Changed Event Args Class

The event arguments used by ComboBox's CurrentChanged event.
Inheritance Hierarchy
System Object
System EventArgs
Autodesk.Revit.UI.Events RibbonItemEventArgs
Autodesk.Revit.UI.Events ComboBoxCurrentChangedEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ComboBoxCurrentChangedEventArgs : RibbonItemEventArgs

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Application The current UIApplication.
(Inherited from RibbonItemEventArgs )
Public property NewValue The current item for the ComboBox after the change.
Public property OldValue The current item for the ComboBox before the change.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also