ConstrainProfiles Method


Form Constrain Profiles Method

Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConstrainProfiles(
	int primaryProfileIndex
)

Parameters

primaryProfileIndex Int32
Index to specify the profile used as primary profile.
Exceptions
Exception Condition
InvalidOperationException This operation can only be performed on a swept blend form.
See Also