Workset |
Indicates if a workset can be deleted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CanDeleteWorkset(
Document document,
WorksetId worksetId,
DeleteWorksetSettings deleteWorksetSettings
)
Parameters
- document Document
- The document containing the worksets.
- worksetId WorksetId
- The id of the workset to delete.
- deleteWorksetSettings DeleteWorksetSettings
- The settings to delete a workset.
Return Value
BooleanTrue if the workset can be deleted, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The workset can't be deleted in the following cases:
- The input worksetId is not valid in the document.
- The input worksetId doesn't represent a user-created workset, which means this workset might be a system workset.
- The workset is not editable by the current user. In order to resolve this problem, please checkout the workset by calling [!:Autodesk::Revit::DB::WorksharingUtils::CheckoutWorksets] .
- The workset or some elements under the workset are owned by the other users. In order to resolve this problem, please ask the other users to call [!:Autodesk::Revit::DB::WorksharingUtils::RelinquishOwnership] to relinquish their ownership on the workset and elements.
- The target workset is not a user-created workset.