End Property


Leader End Property

End point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ End { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentException When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- When setting this property: The leader's End point may not be placed at the current position of the Anchor or Elbow point.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.
Remarks
The End point is the leader's end that points to the object being annotated.
See Also