BuiltInFailures.SweepFailures Class


Built In Failures Sweep Failures Class

Failures about Sweep.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures SweepFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SweepFailures

The BuiltInFailures SweepFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotDrawSweep Can't create sweep.
Public property Static member ComplexPathWithComplexProfile Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
Public property Static member ProfileLoopEmpty Profile sketch is empty!
Public property Static member SweepFailed Proper sweep geometry creation failed.
Public property Static member SweepFailedError Proper sweep geometry creation failed.
Public property Static member WallSweepInconsistent The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.
Top
See Also