CriticalPathCollector Constructor


Critical Path Collector Constructor

Creates a new CriticalPathCollector that visits the analytical segments on the network critical path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CriticalPathCollector(
	Document doc,
	MEPNetworkSegmentId segmentId
)

Parameters

doc Document
The document of the analytical network.
segmentId MEPNetworkSegmentId
The analytical segment to identify the network. Note that this segment is not required to be on the critical path.
Exceptions
Exception Condition
ArgumentException The network segment id is invalid.
ArgumentNullException A non-optional argument was null
See Also