ExportIFCCategoryInfo(Boolean, String, String, String, String) Constructor


Export IFCCategory Info(Boolean, String, String, String, String) Constructor

Constructs a new ExportIFCCategoryInfo with input values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportIFCCategoryInfo(
	bool ifcExportFlag,
	string ifcEntityName,
	string ifcPredefinedType,
	string ifcUserDefinedType,
	string ifcPresentationLayerName
)

Parameters

ifcExportFlag Boolean
The flag that indicates whether the category is exported.
ifcEntityName String
The IFC entity name.
ifcPredefinedType String
The IFC predefined type.
ifcUserDefinedType String
The IFC user defined type.
ifcPresentationLayerName String
The IFC presentation layer name.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also