Create Method (Document, ElementId, LinkElementId, Reference)


Number System Create(Document, Element Id, Link Element Id, Reference) Method

Creates a new instance of a NumberSystem associated to a host element and a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static NumberSystem Create(
	Document document,
	ElementId viewId,
	LinkElementId numberedElementId,
	Reference referenceCurve
)

Parameters

document Document
The document.
viewId ElementId
The view in which the NumberSystem will be created.
numberedElementId LinkElementId
The host id on which the NumberSystem will be created.
referenceCurve Reference
The reference curve along which the NumberSystem will be created. It is suggested to get the new reference via GetNumberSystemReference() from the host element.

Return Value

NumberSystem
The created NumberSystem.
Exceptions
Exception Condition
ArgumentException viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- numberedElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The referenceCurve is not valid for NumberSystem on numberedElementId. -or- The numberedElementId already has a NumberSystem.
ArgumentNullException A non-optional argument was null
See Also