IsValidSolidFillPatternId Method


Filled Region Type Is Valid Solid Fill Pattern Id Method

Checks if the id is valid for a background pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidSolidFillPatternId(
	ElementId patternId
)

Parameters

patternId ElementId
Element id of the FillPatternElement

Return Value

Boolean
False if in a family and the id is a solid fill pattern and 'isMasking' is masking is false. True otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also