CreatePipeConnector Method (Document, PipeSystemType, Reference)


Connector Element Create Pipe Connector(Document, Pipe System Type, Reference) Method

Create a new pipe ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ConnectorElement CreatePipeConnector(
	Document document,
	PipeSystemType pipeSystemType,
	Reference planarFace
)

Parameters

document Document
The document to add the connector to.
pipeSystemType PipeSystemType
The PipeSystemType of the connector.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The pipe ConnectorElement.
Exceptions
Exception Condition
ArgumentException The reference is not a planar face. -or- document is not a family document.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also