Pipe Create(Document, Element |
Creates a new pipe that connects to two connectors.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static Pipe Create(
Document document,
ElementId pipeTypeId,
ElementId levelId,
Connector startConnector,
Connector endConnector
)
Parameters
- document Document
- The document.
- pipeTypeId ElementId
- The ElementId of the new pipe type.
- levelId ElementId
- The level ElementId for the new pipe.
- startConnector Connector
- The first connector where the new pipe starts.
- endConnector Connector
- The second point of the new pipe.
Return Value
PipeThe pipe.

Exception | Condition |
---|---|
ArgumentException | The pipe type pipeTypeId is not valid pipe type. -or- The ElementId levelId is not a Level. -or- The connector domain is not Domain.Piping. -or- The points of startConnector and endConnector are too close: for MEPCurve, the minimum length is 1/10 inch. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Thrown when the new pipe fails to connect with the connector. |

The new pipe will have the same diameter and system type as the start connector. The creation will also connect the new pipe to two component who owns the specified connectors. If necessary, additional fitting(s) are included to make a valid connection. If the new pipe can not be connected to the next component (e.g., mismatched direction, no valid fitting, and etc), the new pipe will still be created at the specified connector position, and an InvalidOperationException is thrown.