ExportUtils Class


Export Utils Class

This class provides utilities related to document export.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExportUtils

The ExportUtils type exposes the following members.

Methods
Name Description
Public method Static member GetExportId(Subelement) Retrieves the GUID representing the subelement in DWF and IFC export.
Public method Static member GetExportId(Document, ElementId) Retrieves the GUID representing this element in DWF and IFC export.
Public method Static member GetGBXMLDocumentId Retrieves the GUID representing this document in exported gbXML files.
Public method Static member GetNurbsSurfaceDataForSurface Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface] .
Top
See Also