Edge Class


Edge Class

An edge of a 3d solid.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Edge : GeometryObject

The Edge type exposes the following members.

Properties
Name Description
Public property ApproximateLength Returns the approximate length of the edge.
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Reference Returns a stable reference to the edge.
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method AsCurve Returns a curve that corresponds to the edge's parametric orientation.
Public method AsCurveFollowingFace Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method ComputeDerivatives Returns the vectors describing the edge at the specified parameter.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method Evaluate Evaluates a parameter on the edge.
Public method EvaluateOnFace Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method GetCurveUV(Int32) Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method GetCurveUV(Int32, Transform2D) Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method GetEndPointReference Returns a stable reference to the start or the end point of the edge.
Public method GetFace Returns one of the two faces that meet at the edge.
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsFlippedOnFace(Face) Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method IsFlippedOnFace(Int32) Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method Tessellate Returns a polyline approximation to the edge.
Public method TessellateOnFace Returns a polyline approximation to the edge in UV parameters of the face.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].
See Also