Document New |
Creates new rooms in each plan circuit found in the given level in the given phase.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- level Level
- The level from which the circuits are found.
- phase Phase
- The phase on which the room is to exist.
Return Value
ICollection ElementIdIf successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved. |
InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation. |
ArgumentException | Thrown if the level does not exist in the given document. |
ArgumentException | Thrown if the phase does not exist in the given document. |