Noise Class


Noise Class

A static class that provides access to the property names that appear in the Noise visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Noise

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Noise

The Noise type exposes the following members.

Properties
Name Description
Public property Static member NoiseColor1 The property labeled "Color 1" from the "Noise" schema.
Public property Static member NoiseColor2 The property labeled "Color 2" from the "Noise" schema.
Public property Static member NoiseLevels The property labeled "Levels" from the "Noise" schema.
Public property Static member NoisePhase The property labeled "Phase" from the "Noise" schema.
Public property Static member NoiseSize The property labeled "Size" from the "Noise" schema.
Public property Static member NoiseThresholdHigh The property labeled "High" from the "Noise" schema.
Public property Static member NoiseThresholdLow The property labeled "Low" from the "Noise" schema.
Public property Static member NoiseType The property labeled "Noise Type" from the "Noise" schema.
Public property Static member TextureAngle The property labeled "Angle" from the "Noise" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Noise" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Noise" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Noise" schema.
Public property Static member TextureRealWorldOffsetZ The property labeled "Offset Z" from the "Noise" schema.
Top
See Also