Marble Class


Marble Class

A static class that provides access to the property names that appear in the Marble visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Marble

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Marble

The Marble type exposes the following members.

Properties
Name Description
Public property Static member MarbleColor1 The property labeled "Stone Color" from the "Marble" schema.
Public property Static member MarbleColor2 The property labeled "Vein Color" from the "Marble" schema.
Public property Static member MarbleSize The property labeled "Vein Spacing" from the "Marble" schema.
Public property Static member MarbleWidth The property labeled "Vein Width" from the "Marble" schema.
Public property Static member TextureAngle The property labeled "Angle" from the "Marble" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Marble" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Marble" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Marble" schema.
Public property Static member TextureRealWorldOffsetZ The property labeled "Offset Z" from the "Marble" schema.
Top
See Also