LinkLoadContent Class


Link Load Content Class

This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinkLoadContent : ExternalResourceLoadContent

The LinkLoadContent type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternalResourceLoadContent )
Public property LoadStatus A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
(Inherited from ExternalResourceLoadContent )
Public property Version The version of the external data that the server is providing in this object.
(Inherited from ExternalResourceLoadContent )
Top
Methods
Name Description
Public method Dispose
(Inherited from ExternalResourceLoadContent )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLinkDataPath Returns the Link data path owned by this LinkLoadContent object.
Public method GetLinkLoadResult Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetLinkDataPath Sets the Link data path owned by this LinkLoadContent object.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

This class handles Revit links.

Revit links must be loaded from a path accessible to Revit. Server implementors should provide Revit with a ModelPath representing a location from which to load the link. Revit will handle the actual file loading.

Servers which represent non-local file locations will need to create their own implementation for copying or moving files to a Revit-accessible location.

The link data path used for link loading may be different from the path displayed to the user. The link data path represents the literal location of the file, whereas the link's display path represents what the user sees as the name of the link. See [!:Autodesk::Revit::DB::ExternalResourceReference::InSessionPath] for more details on display paths.

See Also